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Refine, Validate, and Report 
 

Refinement is simply a way to improve the fit between the measured intensities and the 

intensities calculated from the model.  The peaks in the difference map and the list of worst 

fitting peaks usually suggest which actions are appropriate to improve the next refinement.  If the 

peaks in the difference map are in the locations of hydrogens, then add hydrogens.  If the 

difference map peaks are near (< 0.7 Å) isotropically-refined atoms, then let those atoms refine 

anisotropically.  If the difference map peaks are near anisotropically-refined atoms, then consider 

a disordered model.  Although performing the tasks below in this order may seem slow, 

refinement that is carried out too quickly may lead to a false, local minimum but not the true 

global minimum.  Each time continue to refine the model to convergence, max(|shift|/esd) < 

0.05.   

 

1. Refine all atoms with isotropic displacement parameters and without hydrogens.   

2. Refine heavy atoms with anisotropic displacement parameters.   

3. Add hydrogens to carbons with a riding model.  Use difference maps to locate 

hydrogen(s) bonded to atoms such as N or O.    

4. Refine all non-hydrogen atoms anisotropically.  (Steps 3 and 4 are sometimes switched.) 

5. Change the weighting scheme to make the GoF or S value to be closer to 1.0.  This step 

may need to be done several times.   

6. Check for inappropriate peaks in the difference map or inappropriate displacement 

parameters.  (This may suggest twinning or disorder.)   

7. Check for the presence of secondary extinction.   

8. Check for correct absolute structure.   

 

It is often valuable to use some molecular editor program to speed up analysis of peaks in the 

Fourier maps.  The programs Shelxle, Olex, ORTEP, and XP are among the more commonly 

used programs.  The first three programs in the list are free to academics.  The program Shelxle 

is recommended in this lab because it offers the user nearly complete control of the atom 

parameters file throughout the refinement process.   

 

After an initial model of atoms has been provided by some structure solution method, it is best to 

properly label and sort the atoms in the model file.  In Shelxle, atoms are labeled in the “Rename 

mode” routine.  There is complete control over the Part number, the atom type and number and 

significant control of any suffix.  Once all atoms are labeled, select the “SHELX > Sort atoms” 

routine to carry out the sorting.  The order of sorting can be changed with the “SHELX > Change 

sort order” menu.  Atoms can also be sorted by hand in the *.res file displayed on the right-hand 

panel.  New peaks in the difference map are shown as small, flat-surfaced blocks.  The “Q-Peak 

Legend” button toggles a color coding of the heights of peaks in the difference map.   

 

In the *.res file, be sure to add the following four commands after the UNIT instruction and 

before any atoms: 
 

ACTA 

CONF 

WPDB -2 
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HTAB 

 

The ACTA command tells the refinement program to generate a *.cif file for archiving and 

communicating the crystal structure.  The CONF command asks the program to calculate all 

obvious torsion angles.  The WPDB command tells the program to generate a file in “protein 

data bank” format, because some folks that will see the structure in the future may wish to make 

drawings of the structure with programs that require this type of file.  The HTAB command asks 

the program to calculate possible hydrogen bonds.   

 

 

 
 

Hydrogens can be added using the “Shelx > Automatic H-fix” option shown above.  Refine until 

converged then refine non-hydrogen atoms anisotropically.   

 

When all atoms have been added and refinement has converged, leave the Shelxle program, open 

a command prompt window, and perform one final round of refinement with a *.ins file in which 

the “LIST  6” command has been changed to a “LIST  4”.  This change generates a *.cif with the 

data needed by checkcif to validate the structure.   
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Checklist for a Completed Structure 
 

1. Intensity data should have been collected to at least 0.82Å resolution with at least 98% 

completeness.  If the intensities fall to background values and were truncated at lower 

resolution, describe this in the *.cif file.   

2. Be sure that all bond lengths, angles, and torsion angles are chemically reasonable!   

3. The last difference map should be relatively flat.  No peaks or valleys in the map should 

be > 0.1 * Zmax . 

4. The anisotropic displacement parameters should be only slightly prolate (cigar shaped) or 

oblate (plate shaped).  RIGU, DELU, SIMU, or ISOR restraints may be needed. 

5. If the sample crystallizes in a non-centrosymmetric space group, check that the absolute 

structure has been correctly determined.   

6. The final refinement must be converged -- largest |shift| / esd < 0.05.   

7. The weighting scheme should be adjusted so that the GoF = S  1.0.   

8. The final R1 and wR2 should be reasonably low for the data.  R1 < 0.05 for a good 

structure; R1 < 0.10 for an acceptable structure.   wR2 < 2 * R1.   

 

 

Validate the Structure 
 

First, edit the *.pcf file with the following changes.   

1. Change the space group symbol by removing all parentheses if present and adding spaces 

between symmetry operations that apply in different directions.   

2. The _cell_measurement_reflns_used should be a number > 400.  If not, then find the 

information that needs to be updated from the project._ls file (found near the bottom of 

the file).  Also correct the _cell_measurement_theta_min and _max values.  Note that the 

*._ls file records 2 values, but the *.cif needs  values.   

3. Change the _exptl_absorpt_correction_type value to ‘multi-scan’. 

4. Change the _diffrn_measurement_device_type to ‘Bruker Photon II CMOS’. 

5. Change all references to programs in the _computing items by opening the nearest 

programs.txt file; selecting all contents; copying all contents; in the *.pcf file, selecting 

all lines beginning with _computing; then pasting the information from the programs.txt 

file.   

6. Close and save the *.pcf file and close the programs.txt file. 

 

Second, edit the *.cif file with the following steps.  Open the file with the ENCIFER program.   

1. Comment out the _shelx_SHELXL_version_number line by adding “#” as the first 

character in the line.   

2. Change the _chemical_formula_moiety by deleting the “?” at the end of the line and 

adding a new line with the chemical moiety formula in the format shown below the 

_chemical_formula_sum item.  Remember for each covalently-bonded unit to put carbon 

first, then hydrogen, then all other atom types in alphabetical order.  Separate covalently-

bonded groups with a comma.  For groups with a number other than “1”, put parentheses 

around the formula and insert the number of groups before the leading parenthesis.   

3. Change the value of _exptl_absorpt_correction_T_min from “?” to the T_min value listed 

at the end of the *.abs file.   
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4. Change the value of _exptl_absorpt_correction_T_max from “?” to the T_max value 

listed at the end of the *.abs file.   

5. Change the value of _exptl_absorpt_process_details from “?” to ‘SADABS (Sheldrick, 

2015c)’.  Note use “TWINABS” instead of “SADABS” if that program was used.   

6. Comment out the _exptl_absoprt_special_details line.   

7. Change the _atom_sites_solution_primary from “?” to “dual”. 

8. Change the _atom_sites_solution_secondary from “?” to “difmap”. 

9. If the space group is not centrosymmetric then change the value for 

_chemical_absolute_configuration from “.” to appropriately describe how the correct 

absolute structure was determined, codes can be seen by selecting this data name and 

opening the dictionary (icon of a book with a question mark on front) for this data name.   

10. Check syntax using Tools > Check, correct any problems, save the *.cif, and close the 

program.   

 

Third, run the ciftab program.  The first stage of this program combines the information in the 

*.pcf with the *.cif.  The second stage of ciftab creates a file with tables of data for a report.  In 

the “C” menu item of ciftab type the name of the compound presented by the user.   

 

Validate the structure by running the checkcif program available at:  http://checkcif.iucr.org/  

Locate your *.cif data file, select output as PDF and click Send CIF for checking.   

 

http://checkcif.iucr.org/


OU Chemical Crystallography Lab 5 2/3/2020 

 
 

If there are no syntax problems, a new page will appear with a link to “Download checkcif 

report”.  Save this file with your data files.  If there are issues that can be resolved, modify the 

*.ins file, refine again, change the *.cif as outlined above, run ciftab, and then checkcif.  

Continue until no more resolvable issues remain. 

 

If there are A- or B-level alerts, modify the cif by adding a line with _vrf_platon_alert_code then 

add two lines with “; ”on each line.  Between the semicolon lines, add one line with “Problem:  

platon problem description” and another line with “Response:  your response to this issue”.  

Note if there is more than one Platon alert with the exact same alert code, then append “_a”, 

“_b”, etc, to the _vrf_ lines so that they will be different data items.   

 

A copy of the final checkcif.pdf for this structure is attached as an appendix.   
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Prepare the Report (optional) 
 

Prepare Drawings 

 

Three types of drawings need to be prepared, a capped stick drawing, a thermal ellipsoid drawing 

with all non-hydrogen atoms labelled, and a packing drawing.  If the structure is disordered, then 

make a labelled thermal ellipsoid drawing for each of the disordered groups of the molecule.   

 

There are several free programs for making drawings.  The program mercury is available from 

the makers of the Cambridge Structural Database at  

https://www.ccdc.cam.ac.uk/Community/csd-community/freemercury/ 

 

In mercury, be sure to set the background to white by right-clicking in the background and select 

Display options and in the next menu select the single color of white, then Close.   

 

Select your desired file with File > Open menu, choosing either the *.cif or *.res files.  Set the 

style of your drawing with Display > Style.  Note that parameters such as bond radii, etc., may 

also be changed in one of the Display > Style > Settings options.   

 

The drawing should be oriented to describe the issue you wish to present, and if possible, with 

the narrowest arrangement of atoms from left to right in order to fit in the two-column format 

adopted by most journals.  Also, orient the drawing to have the fewest overlaps of atoms.  The 

orientation can be changed either with x-, x+, y-, y+, z- or z+ buttons or by holding the left 

mouse button down and rotating the mouse.  The relative size of the drawing can be changed by 

holding the right mouse button down and moving the mouse.  Translations of the drawing can be 

changed by holding the center mouse button and moving the mouse.   

 

Drawings are saved by selecting File > Save As, then select the proper directory and file name.  

Save the files as *.jpg or *.png file types.  Because several drawings need to be saved, it is 

recommended that you save them with different file names such as project_a, project_b, etc.  

Adjust the number of pixels to the best choice for your drawing and click Save.  Always check 

your drawing by opening a command prompt window, setting the current directory to the 

directory of the files, and typing project_a.jpg or project_b.png.  If necessary, make adjustments 

to the drawing and save the drawing again.   

 

The default color of the hydrogen atoms will be difficult to see with the white background so 

select Display > Colours > Atoms.  Choose the “Select color” option and then pick a color that is 

not currently being used (gray is recommended).   

 

When labeling atoms, first select the size and colour of the labels by Display > Labels > Label 

Colour or Label Size.  To display the atom labels, select the “Label atoms” button in the options 

panel at the bottom of the screen or check the box before “Show Labels for” on the menu bar.  

All atoms are labeled.  To remove labels from hydrogens select the option “Non-hydrogen 

atoms”.  Move labels so that they do not overlap atoms or bonds by selecting the “Move Labels” 

option in the Picking Mode display and moving the label so that it is near the appropriate atom 

and is not touching any atom or bond.   

https://www.ccdc.cam.ac.uk/Community/csd-community/freemercury/
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To prepare the packing drawing remove “Labeling” and remove hydrogens except hydrogens 

involved in hydrogen bonds and set the style to Ball and Stick.  The radii of the atoms and the 

bonds can be adjusted to taste.  The packing diagram should be drawn by selecting the Packing 

button in the lower Display menu.  The size, colour, and position of the cell axis labels can be 

adjusted in the same manner as the atom labels were adjusted.   

 

Preparing the Report 

 

Open the *.rtf file using the Word® program.  Set the Show/Hide button to show all white space 

characters.  Select the View > Ruler check box.   

 

Delete the first blank space of the document.  For each of the labeled drawings and for the 

packing drawing type a <cntl>-<enter> followed by the up arrow.  Now select “Insert > Object > 

Text from file” and select the E:\template.doc file.  Select and cut the footnote on the third page 

and delete the two blank characters on this page.  Use the page down and/or scroll down buttons 

to move to the bottom of Table 1.  Paste the footnote at the bottom of Table 1.   

 

Move to the first page of the document.  Fill in the sample name, lab identification, user name, 

“moiety” chemical formula, date, and the sponsor of the project.  At the bottom of page 1 insert 

the capped-stick drawing.  Skip page 2 for now.  On page 3, 4, etc. insert the labelled thermal 

ellipsoid drawing(s) and the packing drawing, with one drawing per page.   

 

In the Experimental section make the following changes.  Add any information about twinning 

or occupancies of disordered atoms in the first paragraph.  Also, delete reference “(4)” in the first 

sentence if the OLEX2 program was not used.  Truncate each of the crystal dimensions to show 

only two digits after the decimal points.  In the fifth sentence, change “Semi-empirical from 

equivalents” to just “empirical”.  In the first sentence of the second paragraph, set the first letter 

of the crystal system to lower case and change all letters in the space group name to italics.  If 

there were no hydrogens bonded to nitrogens or oxygens, then delete the sentence describing 

these hydrogens.  Replace question marks in the weighting factor expression with the proper 

terms used in refinement.  (These terms are in the *.cif.)  If the space group is centrosymmetric, 

then delete the last two sentences of paragraph 2.   

 

In the Acknowledgements include your name in the last line.   

 

Edit the references to represent the references used in determining the structure.   

 

In Table 1, change the first letter in the name of the crystal system to lower case.  Change all 

letters in the space group name to italics.  Change the first letter in the Absorption correction 

type to lower case.  If the Extinction coefficient is listed as “n/a” then delete this line.   

 

On Table 3, select all bond distances, and then select Page Layout > Columns > 2.  Then select 

all bond angles, then select Page Layout > Columns > 2, then move the tab shown on the ruler 

from 2” to 2.25”.  If there are no symmetry operations used to generate atoms in Table 3, then 
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delete the line referring to the operations.  If there are symmetry operations, then add a space 

after each comma (,) in the operations.   

 

If there is a Table 6 or 7, then check the line below the table to see if there are symmetry 

operations used to generate atoms.  If there are no operations, delete this line.  If there are 

operations, then put a blank space after the commas in the operations.   

 

Delete the last page (which is blank).   

 

Page through the document and record the page numbers for the start of Tables 3, 4, 5, 6, and 7.  

On the Table of Contents, page 2, correct the page numbers for these tables or delete lines for 

missing tables.  Also, if there is more than one labelled drawing, add a line for each additional 

drawing and update the page numbers for all items in the Table of Contents. 

 

If desired, Insert a page number at the bottom center of each page.   

 

Finally, save this document and save the document as the *.pdf.  Exit the word processing 

program.   

 


